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Goal: integrate spatially-misaligned data

Figure 1: We’ll make this Figure 2: You’ll make this
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Scatterplots: plots displaying data as points, with one variable on the horizontal axis
and another on the vertical axis

Figure 3: Scatterplots are useful to
assess direction/strength of
correlations Figure 4: . . . and to identify outliers
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Overview of lab exercise and problem set

1. Lab exercise
a) Use areal interpolation to estimate per capita crime in DC electoral districts
b) Create a scatterplot of electoral competitiveness and per capita crime in DC

2. Problem set
a) Use areal interpolation to estimate racial makeup of DC school zones
b) Create a scatterplot of racial disparities in school performance in DC
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Use case: different data are collected for different spatial units

Figure 5: Elections @ single-member districts Figure 6: Population counts @ census tracts
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Solution: change the support of the data → single member districts

Figure 7: Count crimes in SMDs Figure 8: Interpolate population to SMDs
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Analyze relationship between electoral competitiveness and per capita crime in SMDs

Figure 9: Scatterplot
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The problem set will investigate a similar use case

Figure 10: Scores @ school attendance zones Figure 11: Demographics @ census tracts
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Solution: change the support of the data → school attendance zones

Figure 12: Interpolate demographics to SAZs
Figure 13: Scatterplot
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You can make these plots in QGIS or in R. Instructions for both are below.

Figure 14: Scatterplot 1 in R Figure 15: Scatterplot 2 in R
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We have four (and a half) sources of data:

Category Type Format Data source

Single member districts Vector (polygon) .geojson DC OpenData
ACS DC Census Tract Vector (polygon) .geojson DC OpenData
Crime Incidents in 2024 Vector (point) .geojson DC OpenData
School Attendance Zones, Elementary Vector (polygon) .geojson DC OpenData
+ School STAR Scores Table (non-spatial) .csv DC OpenData

These are all in the PS07.zip file posted on Canvas.

Let’s open QGIS. . .
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https://opendata.dc.gov/datasets/DCGIS::single-member-district-from-2023/about
https://opendata.dc.gov/search?collection=Dataset&q=acs%20tract
https://opendata.dc.gov/datasets/DCGIS::crime-incidents-in-2024/about
https://opendata.dc.gov/datasets/DCGIS::school-attendance-zones-elementary/about
https://opendata.dc.gov/datasets/DCGIS::school-star-scores/about
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Interpolation
Scatterplot

QGIS
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Interpolation
Scatterplot

Always save your progress!
Go to Project → Save As...
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Interpolation
Scatterplot

Interpolation
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Load the Single Member Districts file:
Layer → Add Layer → Add Vector Layer...
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Navigate to the SMD_2022.geojson file in the Data/Elections directory:
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Interpolation
Scatterplot

The SMD_2022 layer should appear in you project window. These polygons are the
lowest-level electoral units in DC (DC has 8 Wards, 46 Advisory Neighborhood
Commissions, 345 SMDs)
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Load the crime incidents vector data:
Navigate to the Crime_Incidents_in_2024.geojson file in Data/Crime
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The Crime_Incidents_in_2024 layer should appear in the project window. These
are points, representing the locations of reported crimes
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The third set of data we need is the ACS_2020.geojson file in Data/ACS folder
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Interpolation
Scatterplot

This layer contains American Community Survey data on local demographics
(including population counts, which we need to estimate per capita crime). These
data are at the level of Census Tracts, the borders of which do not align with SMDs
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Scatterplot

Our first order of business is to construct the area weights we will be using for
interpolation, starting with aj (area of destination polygons). Open the Attribute
Table for SMD_2022 (destination layer) and open the Field Calculator
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Interpolation
Scatterplot

Create a new field called smd_area of type Decimal number (real).
Set the Expression to $area
This will give us the area calculation for destination polygons (in square meters)
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Interpolation
Scatterplot

The new field smd_area should appear in the Attribute Table for SMD_2022
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Remember to save your layer edits after every operation like this! Right-click on
SMD_2022 → Save Layer Edits (simply entering Ctrl-S or Cmd-S will save the
project file, but not the underlying data layers we are editing)
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Let’s also calculate the area of source polygons (ai). Open the Field Calculator for
ACS_2020 and create a new field called tract_area of type Decimal number
(real). Set the Expression to $area
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Let’s calculate the number of crimes in each SMD (the "nominator" of our future
interpolated variable).
Go to Vector menu → Analysis Tools → Count Points in Polygon...
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Select SMD_2022 as the Polygons layer and Crime_Incidents_in_2024 as the
Points layer. Name the count field crimes_smd_2024 and save the output to a new
file called SMD_2022_2.geojson. Click Run
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You may see a No spatial index... warning message in the log, but this won’t
affect the calculation (only the processing speed). Just be patient and wait for the
algorithm to finish
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The newly-created SMD_2022_2 layer should appear in the project window. You can
hide the other two layers for now, if you like
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Check the Attribute Table for SMD_2022_2 to make sure the crimes_smd_2024
variable is there
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To facilitate a “whole vs. parts” comparison (i.e. transforming a variable directly
versus reconstructing it from transformed components) we can do the same kind of
points-in-polygons calculation with the ACS_2020 layer. . .
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Interpolation
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Same approach as before, except with ACS_2020 as polygon layer,
crimes_tract_2024 as field name, and ACS_2020_2.geojson as output file
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The new ACS_2020_2 layer should appear in the project window.
Let’s open its Attribute Table
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Make sure the crimes_tract_2024 variable is there.
Then launch the Field Calculator
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Calculate the “crimes per 1000 residents” variable for ACS_2020_2. Name the field
crimes_1000_tract, set type to Decimal number (real), and set the
Expression to crimes_tract_2024 / POP_TOTAL * 1000
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The new crimes_1000_tract variable should appear in the Attribute Table
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Remember to save your layer edits!
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The next step is to calculate the area of each intersection between source and
destination polygons, or ai∩j . To do this, we first need to create the intersection.
Go to Vector menu → Geoprocessing Tools → Intersection...
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Scatterplot

For the intersection, select SMD_2022_2 as Input Layer, ACS_2020_2 as Overlay
layer. Then click the [...] button next to “Overlay fields to keep”
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On the next screen check the boxes next
to

- ✓ POP_TOTAL
- ✓ crimes_tract_2024
- ✓ crimes_1000_tract
- ✓ tract_area

Click OK

Yuri M. Zhukov API-231 / GIS-PubPol / 13



QGIS
R

Interpolation
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Save the output file to SMD_ACS_intersection.geojson, click Run
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The SMD_ACS_intersection layer should appear in your project window
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Open the Attribute Table for SMD_ACS_intersection and launch the Field
Calculator
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Create a new field called area_weight of type Decimal Number (real).
Set Expression to $area / tract_area (this is equivalent to w

(ext)
i∩j = ai∩j

ai
)
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The area_weight field should appear in the Attribute Table.
Now go back to the Field Calculator, where we will create weighted population
variables for destination polygons
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Now let’s sum the weighted population numbers for each SMD. Create a new field
called pop_tract2smd of type Decimal Number (real). Set Expression to
sum(POP_TOTAL*area_weight,group_by:=SMD_ID)
(this is equivalent to

∑
i∩j w

(ext)
i∩j xi∩j)
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This will take several minutes to compute (you can follow the progress bar at
bottom, or use this time to stretch your legs)
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(OPTIONAL) Create a new field called area_weight2 of type Decimal Number
(real).
Set Expression to $area / smd_area (this is equivalent to w

(int)
i∩j = ai∩j

aj
)
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Now let’s do a weighted average (intensive) of crimes per 1000 residents. Create a
new field called crimes_1000_tract2smd of type Decimal Number (real). Set
Expression to sum(crimes_1000_tract*area_weight2,group_by:=SMD_ID)
(this is equivalent to

∑
i∩j w

(int)
i∩j xi∩j)
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(OPTIONAL) This will also take a while to run. I even received a “program not
responding” message, which I ignored (but check the progress bar to make sure the
program is actually still running)
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When it finishes running, you will see both new variables in the Attribute Table.
Note that these values should be constant within SMDs (i.e. values will be repeated
for intersections within each destination polygon)
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After the algorithm finishes running is a good time to save your layer edits!
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Our next step is to import these weighted values into the SMD_2022_2 layer, and
divide crimes by population size. Right-click on SMD_2022_2 → Properties
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Go to Joins tab in SMD_2022_2 Properties and click + button to add a new join
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Set SMD_ACS_intersection as the “Join layer”, SMD_ID as the “Join” and
“Target” field, and under “Joined fields” select ✓ pop_tract2smd and ✓
crimes_1000_tract2smd (if you created this variable, too). Check the box next to
Custom field name prefix and clear the contents (i.e. no prefix). Click OK
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You should now see the new join layer in Properties
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Quality check! Let’s see if the sum of interpolated population values is close to the
sum of this variable in the original data. Go to Vector menu → Vector Analysis
→ Basic Statistics for Fields
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In the next window, set “Input layer” to SMD_2022_2 and “Field” to
pop_tract2smd. Click Run
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Make note of the value in the log after “SUM:”
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Now do the same with “Input layer” ACS_2020 and “Field” POP_TOTAL
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The population sums look numerically close (683,027 vs 683,154).
Interpolation was a success!
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Last step (for interpolation): calculate number of crimes per 1000 residents! Go to
the Attribute Table for SMD_2022_2 and open the Field Calculator
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Create a new field called crimes_1000_smd of type Decimal number (real).
Set Expression to crimes_smd_2024 / pop_tract2smd * 1000
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(OPTIONAL) Whole vs. parts: compare the values for the field we just constructed
(crimes_1000_smd) from components to the crimes_1000_tract2smd variable
we interpolated whole-cloth.
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Save the edits to the SMD_2022_2 layer!
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To be extra-safe, let’s export the layer to a new geojson file (to preserve the join).
Right-click SMD_2022_2 in layer menu → Export → Save Features As...

Yuri M. Zhukov API-231 / GIS-PubPol / 13



QGIS
R

Interpolation
Scatterplot

Save the layer as SMD_2022_3.geojson with Geometry type: Polygon. Check the
box next to Extent (current: layer). Click OK
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The new layer should appear in your project window.
Now we’re ready to make a scatterplot of electoral competitiveness and crime!
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Scatterplot
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To make the scatterplots, we will be using the DataPlotly plugin.
Go to View menu → Panels → ✓ DataPlotly
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In the DataPlotly panel, set the following parameters:
Plot type: Scatter Plot; Layer: SMD_2022_3; X field: competitive_top1; Y
field: crimes_1000_smd; Legend title: [empty]
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In the Layout Options tab, set the
following parameters:

- Show legend: □ (off)
- Plot title:

Electoral competitiveness and
crime in DC

- X label:
Top-1 competitiveness (2022)

- Y label:
Crimes per 1000 residents
(2024)

- Click Create Plot
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The scatterplot should appear on the next screen.
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To save the scatterplot, click the Export as image button in lower-right corner
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Name the file scatterplot_competitiveness_crime.png.
It should look something like this:
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Problem Set 7
Your assignment (if using QGIS): create a
scatterplot of school performance and race

- perform areal interpolation:
- source polygons: ACS census tracts

(ACS_2020.geojson)
x variables: neighborhood
population size and racial makeup

- destination polygons: elementary
school attendance zones
(SAZ_Elementary.geojson)
y variables: STAR school
performance scores

- make and export a scatterplot:
- percent non-white on x-axis
- school STAR score on y-axis
- name the file

scatterplot_race_schools.png
- upload plot to Canvas Figure 16: Can you make this?
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Here’s a quick preview of the assignment.
Load the vector data file SAZ_Elementary.geojson from Data/Schools
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To see how SAZ_Elementary overlays with census tracts, select a symbology with
bright thick borders and a transparent inside, like outline_red
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Because SAZs are (mostly) larger and fewer in number than tracts (74 vs 206), it
seems more appropriate for SAZs to be the destination units
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Let’s construct the area weights, starting with the area of destination polygons, aj .
Recall that we already calculated the area of source polygons, ai (tract_area in
ACS_2020). Go to the Field Calculator for SAZ_Elementary
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Create a new field named saz_area of type Decimal number.
Set the expression to $area
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Remember to save your layer edits regularly!
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Now let’s intersect SAZ_Elementary with ACS_2020 to calculate intersection areas,
ai∩j . Go to Vector menu → Geoprocessing Tools → Intersection...
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For the intersection, select SAZ_Elementary as Input Layer, ACS_2020 as Overlay
layer. Then click the [...] button next to “Overlay fields to keep”
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On the next screen check the boxes next to ✓ POP_TOTAL, ✓ RACE_WHITE,
✓ PCT_NONWHITE and ✓ tract_area. Click OK
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Save the output file to SAZ_ACS_intersection.geojson, click Run
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The intersection should appear in your project window
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Launch the Field Calculator for SAZ_ACS_intersection
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Create a new field area_weight of type Decimal number.
Set expression to $area / tract_area. Click OK
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(OPTIONAL) For the intensive transformation, create a new field area_weight2 of
type Decimal number. Set expression to $area / saz_area. Click OK
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Create a new field pct_nonwhite_saz of type Decimal number. Set expression to
sum((POP_TOTAL - RACE_WHITE) * area_weight,group_by:=OBJECTID) /
sum(POP_TOTAL * area_weight,group_by:=OBJECTID) * 100
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(OPTIONAL) Create a new field pct_nonwhite_tract2saz of type Decimal
number. Set expression to
sum(PCT_NONWHITE * area_weight2,group_by:=OBJECTID)
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Inspect the pct_nonwhite_saz variable in the Attribute Table.
Is it constant within SAZs? If so, we’re ready to join it to the SAZs
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Now let’s import these weighted values into the SAZ_Elementary layer. Right-click
on SAZ_Elementary → Properties
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Go to Joins tab and click + to add a new join. Set SAZ_ACS_intersection as
the “Join layer”, NAME as the “Join” and “Target” field, and under “Joined fields”
select ✓ pct_nonwhite_saz and ✓ pct_nonwhite_tract2saz (if you created
this variable, too). Check the box next to Custom field name prefix and clear
the contents (i.e. no prefix). Click OK
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You should now see the new join layer in Properties
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Export the layer to a new geojson file (to preserve the join). Right-click
SAZ_Elementary in layer menu → Export → Save Features As...
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Save the layer as SAZ_Elementary_2.geojson with Geometry type: Polygon.
Check the box next to Extent (current: layer). Click OK
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In the DataPlotly panel, set the following parameters:
Plot type: Scatter Plot; Layer: SAZ_Elementary_2; X field:
pct_nonwhite_saz; Y field: STAR_Score; Legend title: [empty]
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In the Layout Options tab, set the
following parameters:

- Show legend: □ (off)
- Plot title:

Race and school performance
in DC

- X label:
Percent non-white population

- Y label:
School performance (STAR
Score)

- Click Create Plot
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The scatterplot should appear on the next screen.
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Export the image as scatterplot_race_schools.png.
It should look something like this:
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R
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Loading R packages

To implement these steps in R, we will be using the sf and SUNGEO packages
library(sf)
library(SUNGEO)

NOTE: The demo code for R is in ps07_demo.R on RStudio Cloud, and in
PS07.zip (posted on Canvas).
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Interpolation
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Loading spatial data

Let’s load the single member district boundaries into R, using sf::read_sf():
smd_2022 = sf::read_sf("Data/Elections/SMD_2022.geojson")
plot(smd_2022["geometry"])

Yuri M. Zhukov API-231 / GIS-PubPol / 13



QGIS
R

Interpolation
Scatterplot

Now load the ACS census tracts into R:
acs_2020 = sf::read_sf("Data/ACS/ACS_2020.geojson")
plot(acs_2020["geometry"])
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. . . and the crime incidents data:
crimes_2024 = sf::read_sf("Data/Crime/Crime_Incidents_in_2024.geojson")
plot(crimes_2024["geometry"])
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Let’s calculate relative scale and nesting metrics for a change of support from
acs_2020 (census tracts) to smd_2022 (single member districts)
SUNGEO::nesting(acs_2020,smd_2022,metrix=c("rn","rs"))
## $rn
## [1] 0.4594585
##
## $rs
## [1] 0.1793275

Yikes! What if we switched to (smaller) census block groups as source units?
census_2020 = sf::read_sf("Data/Census/CENSUS_2020.geojson")
SUNGEO::nesting(census_2020,smd_2022,metrix=c("rn","rs"))
## $rn
## [1] 0.6907815
##
## $rs
## [1] 0.8217758

Much better! But for consistency with QGIS, we’ll stick with the tracts here.
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Let’s do some point-in-polygon analysis to count crimes per SMD:
smd_2022$crimes_smd_2024 = lengths(sf::st_intersects(smd_2022,

crimes_2024))
plot(smd_2022["crimes_smd_2024"])
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Let’s interpolate population counts per SMD (this is a one-step routine in R)
smd_2022$pop_tract2smd = sf::st_interpolate_aw(acs_2020["POP_TOTAL"],

smd_2022,extensive=TRUE)$POP_TOTAL
plot(smd_2022["pop_tract2smd"])
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Let’s check the quality of transformation: how close are the population counts?
sum(smd_2022$pop_tract2smd) # Interpolated

## [1] 683070.1

sum(acs_2020$POP_TOTAL) # Original

## [1] 683154
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Let’s calculate crimes per 1000 residents
smd_2022$crimes_1000_smd = smd_2022$crimes_smd_2024/

smd_2022$pop_tract2smd*1000
plot(smd_2022["crimes_1000_smd"])
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Scatterplot
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Let’s create the scatterplot
plot(x=smd_2022$competitive_top1,

y=smd_2022$crimes_1000_smd,
xlab="Top-1 competitiveness (2022)",
ylab="Crimes per 1000 residents (2024)",
main="Electoral competitiveness and crime in DC"
)

Yuri M. Zhukov API-231 / GIS-PubPol / 13



QGIS
R

Interpolation
Scatterplot

0.0 0.1 0.2 0.3 0.4 0.5 0.6

0
10

20
30

40

Electoral competitiveness and crime in DC

Top−1 competitiveness (2022)

C
rim

es
 p

er
 1

00
0 

re
si

de
nt

s 
(2

02
4)

Yuri M. Zhukov API-231 / GIS-PubPol / 13



QGIS
R

Interpolation
Scatterplot

Problem Set 7
Your assignment (if using R):

- create a scatterplot of race and
school performance in DC!

- perform areal interpolation:
- source polygons:

AFS_2020.geojson
- y variables: POP_TOTAL and

RACE_WHITE
- destination polygons:

SAZ_Elementary.geojson
- y variables: STAR_Score

- make and export a scatterplot:
- percent non-white on x-axis
- school STAR score on y-axis
- name the file

scatterplot_race_schools_R.png
- upload map to Canvas

(by next Wednesday)

Figure 17: Can you make this?
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